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Error outputted in Flume log "_The znode for the -ROOT- region doesn’t exist!_

Issue

The following error can be outputted in Flume log for:

  • ERROR [lifecycleSupervisor-1- 2-EventThread] (org.hbase.async.HBaseClient$ZKClient$ZKCallback.processResult:3107) - The znode for the -ROOT- region doesn’t exist!

The error can be outputted in the following log(s):

  • flume-interset_<ds>_events_<did>_<tid>_hbase.log 

Cause

The cause is either the master node or regional node not being responsive or down when Flume is attempting to write data to Hbase tables.

Resolution Steps

There are several steps to resolve this issue:

  • Validate Master Node
  • Check HBase Master log for errors
  • Validate HBase RegionServers
  • Check HBase RegionServers log for errors

Validate Master Node

  1. Open up a web browser and navigate to to the Ambari UI URL:
  2. Log into the Ambari UI as the Ambari admin. The default credentials for the Ambari admin user are as follow:
    • Username: admin
    • Password: admin
  3. Once logged in, click on HBase (from component list)
  4. Under the Summary section, ensure that HBase Master is Started.
  5. If HBase Master is Stopped, please start HBase Master.

Check HBase Master log for errors

  1. SSH to MASTER NODE as Interset User
  2. Type in the following to list all HBase logs:
    • ls -al /var/log/hbase
  3. To view the respective log information, see the example below:
    • EXAMPLE: less hbase-hbase-master-<MASTER_NODE_FQDN>.log
  4. Hit the following key combination to go to the bottom of the log file:
    • SHIFT + G
  5. Search backward for “ERROR
    • ? + ERROR
  6. If the last ERROR found is not relative to the current timestamp (minutes), then it may be ignored.
  7. If the ERROR found is relative to the current timestamp (minutes), please consult the Interset Knowledgebase.
  8. If no KB articles are found for the error, please contact Interset Support.

Validate HBase RegionServer 

NOTE: If Ambari is still logged in, please go to step 5. 

  1. Open up a web browser and navigate to to the Ambari UI URL:
    • EXAMPLE: http://<AMBARI_NODE_FQDN>:8080
  2. Log into the Ambari UI as the Ambari admin. The default credentials for the Ambari admin user are as follow:
    • Username: admin
    • Password: admin
  3. Once logged in, click on HBase (from component list)
  4. Under the Summary section, ensure that HBase RegionServers are Started.
  5. If HBase RegionServer is Stopped, please click on the RegionServer link, click on the node FQDN link with the Stopped RegionServer, and beside RegionServer / HBase click the dropdown, click Start and then OK.

Check HBase RegionServer(s) log for errors

  1. SSH to COMPUTE NODE as Interset User
  2. Type in the following to list all HBase logs
    • ls -al /var/log/flume
  3. To view the respective log information, see the example below
    • less hbase-hbase-regionserver-<COMPUTE_NODE_FQDN>.log
  4. Hit the following key combination to go to the bottom of the log file
    • SHIFT + G
  5. Search backward for “ERROR
    • ? + ERROR
  6. If the last ERROR found is not relative to the current timestamp (minutes), then it may be ignored.
  7. If the ERROR found is relative to the current timestamp (minutes), please consult the Interset Knowledgebase.

If no KB articles are found for the error, please contact Interset Support (support@interset.com).

Applies To

  • Interset 5.4.x or higher
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