Follow

HDP 2.5 may fail to install on EL7

During a cluster install, the DataNode may fail to install with the following error:

resource_management.core.exceptions. Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install snappy-devel' returned 1. Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20) Requires: snappy(x86-64) = 1.0.5-1.el6 Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda/7.1) snappy(x86-64) = 1.1.0-3.el7 Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20) snappy(x86-64) = 1.0.5-1.el6

Hadoop requires the snappy-devel package that is a lower version that what is on the machine already. Run the following on the host and retry.

Interset recommends to check snappy (snappy-devel) package version prior to running Ambari / HDP cluster installation.

Example:

yum list installed | grep snappy
snappy.x86_64 1.1.0-3.el7 @anaconda

If the version is not: 1.0.5-1, then remove existing snappy package and install snappy-devel package available on HDP-UTILS repo:

yum remove snappy
yum install snappy-devel

yum list installed | grep snappy
snappy.x86_64 1.0.5-1.el6 @HDP-UTILS-1.1.0.21
snappy-devel.x86_64 1.0.5-1.el6 @HDP-UTILS-1.1.0.21

Once snappy / snappy-devel packages version 1.0.5-1 is installed, you may proceed with Ambari cluster and HDP components installation.

This is a known issue with Hortonworks, further information is available @ https://docs.hortonworks.com/HDPDocuments/Ambari-2.2.1.1/bk_ambari_troubleshooting/content/_resolving_cluster_install_and_configuration_problems.html

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments